The Hyundai Scoupe Forum

All about the Hyundai Scoupe
 
HomeRegisterLog in
Top posters
ScoupeGT
 
Automatik S-Coupe
 
Knutschochse
 
Scoupe
 
Raven
 
MAD_SCOUPE
 
herb524
 
BoostedScoupe
 
mimar999
 
Niky
 
Latest topics
» chasis number
Tue Oct 22, 2013 11:55 am by Automatik S-Coupe

» engine number
Wed Oct 16, 2013 2:51 pm by mimar999

» left window
Fri Dec 14, 2012 10:30 pm by Automatik S-Coupe

» Need Help finding this stuff
Thu Jul 26, 2012 9:03 pm by Automatik S-Coupe

» Bigger brake disks
Tue Dec 13, 2011 7:12 pm by Automatik S-Coupe

» tranny swap
Wed Nov 02, 2011 3:53 pm by Automatik S-Coupe

» scoupe parts replacement
Sat Jun 04, 2011 10:38 pm by Automatik S-Coupe

» Strut brace
Mon May 02, 2011 7:26 am by Knutschochse

» digital air/fuel ratio gauge
Mon May 02, 2011 7:25 am by Knutschochse

Who is online?
In total there is 1 user online :: 0 Registered, 0 Hidden and 1 Guest

None

Most users ever online was 19 on Fri Jan 23, 2015 4:41 am

Share | 
 

 Help needed with AFC

Go down 
AuthorMessage
ScoupeGT
Admin
Admin
avatar


PostSubject: Help needed with AFC   Sat Jan 29, 2011 5:28 pm

Hey guys
today i went installing the SAFC.I followed exactly the installations from the electric diagram of apexi.....
I initialized it (as it was used) and i made the first set ups.
When i turned on the engine there Was a mess..Rough idling going steady for a while and then dropped.This happens continuously
The safc screen shuts off every time the idle fells and then it turns back on...This happens continuously too with engine on....(i know that when the maf signal IN or OUT isnt connected the screen doesnt turn on)
I have engine fault 3117 (maf sensor short circuit).
I double and triple checked wiring and it was ok....Pulling off the maf plug this stops....but the car doesnt work right.....I replaced maf but the same.....what IS THIS????????
Oh i have taken power from pin 18 for the safc...is it possible that this is a prob?
I have connected signal in (white wire) to maf side and yellow as signal out ecu plug side.......why there is no signal?
Ι also noticed that with engine off when i press the throttle on the analog meter the indicator gos to 100%..Ileave the throttle but the indication doesnt drop...it stays at 100%

_________________
Scoupe legend revives.....


Last edited by ScoupeGT on Sun Jan 30, 2011 3:56 pm; edited 1 time in total
Back to top Go down
http://hyundaiscoupe.forumotion.com
Automatik S-Coupe
Silver Star Member
Silver Star Member



PostSubject: Re: Help needed with AFC   Sat Jan 29, 2011 10:52 pm

pin 18 is okay...when the wiring is corect then the adjustments are wrong...did you have select hotwire sensor and did you have the same sensor types as in and out? the throttle is also set the rigt type?
Back to top Go down
ScoupeGT
Admin
Admin
avatar


PostSubject: Re: Help needed with AFC   Sat Jan 29, 2011 10:58 pm

yes about the hotwire sensor and the same sensor types as in and out
but what do you mean about the throttle?
Why then i have a maf malfunction and check engine and the afc turns off and on when idle speed falls?

_________________
Scoupe legend revives.....
Back to top Go down
http://hyundaiscoupe.forumotion.com
Automatik S-Coupe
Silver Star Member
Silver Star Member



PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 11:05 am

you have 2 throttle types falling and rising 5V! The probems you have I dont know such things with the afc
Back to top Go down
ScoupeGT
Admin
Admin
avatar


PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 12:41 pm

Throttle set to rising!
It is crazy ...i reconnected the maf signal as original with all other cables on and then i need to ground the yellow output wire for the car to work...??><I disconnected the power of the afc but the same....
I took them all out and works normally......
Something is wrong with the whole thing....Are you sure about connecting the rpm signal to ignition coil?There sure is a shortcirquit somewhere but i cannot understand Mad
The fact is that when all connected the idle suddenly falls, the afc turns off, the idle rises afc turns on and all the same from the beginning...Also engine light turns on with 3117 fail

_________________
Scoupe legend revives.....
Back to top Go down
http://hyundaiscoupe.forumotion.com
Automatik S-Coupe
Silver Star Member
Silver Star Member



PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 2:55 pm

yes rpm signal for ignition on ecu pin 1 you could also try it from the rpm gauge
Back to top Go down
ScoupeGT
Admin
Admin
avatar


PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 2:57 pm

ok please lets go step by step tell me one by one the pins .....and then basic adjustments of afc just to recheck.....I dont think there is a problem but anyway....
even all throttle hi-lo settings to 0 the same happens

_________________
Scoupe legend revives.....
Back to top Go down
http://hyundaiscoupe.forumotion.com
Automatik S-Coupe
Silver Star Member
Silver Star Member



PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 3:24 pm

okay rpm from apexi to ecu pin 1
maf input apexi to maf pin 3
maf output apexi to ecu pin 7
trottle apexi to ecu pin 53
ground ecu pin 19 one ner to ecu and one a litte bit away

adjustments all zero
maf in and out what you want
throttle rising
Back to top Go down
ScoupeGT
Admin
Admin
avatar


PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 3:39 pm

wow wow wow ........!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
(maf input apexi to maf pin3 - maf output7 apexi to ecu pin )
i cuted cable from pin 7 that goes to the ecu (green red) and i installed in between the apexi in and out (I think this is what you mean right?)
Also i used pin2 with black an brown cable as told as ground
Power i took from pin 37.
so i do not thing there is a problem iwith connection

_________________
Scoupe legend revives.....
Back to top Go down
http://hyundaiscoupe.forumotion.com
Automatik S-Coupe
Silver Star Member
Silver Star Member



PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 5:22 pm

pin2 from maf or ecu? as ground? I think thats not could be the problem because it is only ground for maf

the rest seems to be okay
Back to top Go down
ScoupeGT
Admin
Admin
avatar


PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 5:24 pm

ECU !i believe that too ...
the problem is that when in and out are connected to the apexi i have an engine light meaning the is something going on with the signal....
Is it possible this comes from adjustments?

_________________
Scoupe legend revives.....
Back to top Go down
http://hyundaiscoupe.forumotion.com
Automatik S-Coupe
Silver Star Member
Silver Star Member



PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 7:02 pm

pin 2 on ecu is wrong!!! thats the signal for the engine light!
Back to top Go down
ScoupeGT
Admin
Admin
avatar


PostSubject: Re: Help needed with AFC   Sun Jan 30, 2011 11:24 pm

I was searching again about it and i saw it!just before you send me the reply! I dont know from where i saw that pin 2 was ground........(stupid me!!!!!!)Thank you for your trouble man!!!!

_________________
Scoupe legend revives.....
Back to top Go down
http://hyundaiscoupe.forumotion.com
ScoupeGT
Admin
Admin
avatar


PostSubject: Re: Help needed with AFC   Wed Feb 02, 2011 10:22 pm

ok installed it... can someone enlighten me how to adjust the best way?

_________________
Scoupe legend revives.....
Back to top Go down
http://hyundaiscoupe.forumotion.com
Automatik S-Coupe
Silver Star Member
Silver Star Member



PostSubject: Re: Help needed with AFC   Thu Feb 03, 2011 3:28 pm

its realy simpel

first you choose the percentage of high and low throttle I made is so...in low throttle I have no adjustments...hig begins with 30%
then you look at your rpm's when it begins to cut...then go to the adjustments and try from this rpm to adjust -percentage airmass when it's could outside it could be -20% and when ist warm it could be -8% at same rpm and throttle...and begin a few rpm's earlier with light - adjustments
Back to top Go down
ScoupeGT
Admin
Admin
avatar


PostSubject: Re: Help needed with AFC   Thu Feb 03, 2011 7:17 pm

so the general idea is to adjust less air?

_________________
Scoupe legend revives.....
Back to top Go down
http://hyundaiscoupe.forumotion.com
Automatik S-Coupe
Silver Star Member
Silver Star Member



PostSubject: Re: Help needed with AFC   Thu Feb 03, 2011 9:01 pm

yes so that you dont get 5V from maf to ecu! because of that you need bigger injectors
Back to top Go down
Sponsored content




PostSubject: Re: Help needed with AFC   

Back to top Go down
 
Help needed with AFC
Back to top 
Page 1 of 1

Permissions in this forum:You cannot reply to topics in this forum
The Hyundai Scoupe Forum :: Problems & Solutions :: Electrical Problems-
Jump to: